macworld news antenna

Adobe will fix a vulnerability in Flash and Acrobat

The bug has been located by Adobe engineers in the authplay.dll file and may allow a hacker to infiltrate the system with potential control over the system. This vulnerability affects Adobe Flash Player versions 10.0.45.2, 9.0.262, and 10.0.x earlier, whether for Windows, Macintosh, Linux, or Solaris.

Also, Adobe has encountered the same bug in earlier versions of Adobe Reader and Acrobat 9.3.2 and 9.x for Windows, Macintosh, and Unix. The company plans to release this patch on June 29.

These Adobe updates will also include enhancements to Flash Player 10.x on Windows, Macintosh, and Linux. However, the Flash Player 10 update for Solaris does not yet have a release date.

On the other hand, Adobe has added that the versions of Flash 10.1 RC have not been compromised by this vulnerability.